How to install Perl 6 in Ubuntu

I’m disappointed in the results when you google how it install Perl 6.

  • Building from source is unnecessarily complicated.
  • The PPA I found is out of date.

But we have saviors! The Debian Rakudo Maintainers. The latest Perl 6 version is available in Debian Sid. Here’s how to enable it in Ubuntu. I’m running Ubuntu 17.10 Artful Aardvark, so if you’re running something else, YMMV.

Create the file /etc/apt/sources.d/deb-debian-org-sid.list containing

I included [allow-insecure=yes] because I needed it to satisfy my apt setup since I have some repos set up over https and I could not find a GPG key for Try it without first. If you get the error

then you need it.

Then I went back to /etc/apt/sources.d/deb-debian-org-sid.list and commented out the first line so as to not accidentally upgrade any other packages to the bleeding edge sid versions. Then one more

and confirm that the sid repo doesn’t show up and has been successfully disabled.